Double-H DH-BT045-DH-BT-TB USB.Bluetooth Download Drivers

Available 1 files for DH-BT045-DH-BT-TB USB.Bluetooth
Company
Double-H
Categories
Other Peripherals
Model
Double-H DH-BT045-DH-BT-TB USB.Bluetooth
Description
InstAllation Driver
Operating Systems
Windows 98Se-Me-2000-XP
Version Driver
3.03
Size Driver
19.1Mb
File Name
usb.zip
Info
1 INTRODUCTION........................................................................................................1
1.1 OPEN THE PROGRAM.................................................................................................1
2 THE SPYLITE TRACE WINDOW................................................................................2
3 MENUS & TOOLBAR.................................................................................................3
3.1 FILE MENU.............................................................................................................4
3.2 EDIT MENU.............................................................................................................5
3.3 TOOLS MENU..........................................................................................................6
3.3.1 Format..........................................................................................................6
3.3.2 File Logging Options.......................................................................................8
3.3.2.1 Saving log files for trace......................................................................9
3.3.3 Set Protocol Trace........................................................................................11
3.3.4 Clear Trace.................................................................................................11

1 Introduction
The BTServer SpyLite (SpyLite) application is part of WIDCOMM’s BTW software. The application allows the user to monitor Bluetooth trace information based on BTW software version dependent profiles. You will have received the SpyLite application that matches your selection of profiles in BTW
SpyLite monitors Bluetooth activity; when the application is open, the current activity is displayed in the trace window in the sequence that the Bluetooth devices send and respond to each other.
Some knowledge of the sequence of Bluetooth events is necessary to understand the information that is displayed.
Data throughput analysis and data integrity check-functions are incorporated into the displayed results
1.1 OPEN THE PROGRAM
Double-click SpyLite.exe in the BTW installation folder to run the program.
2 The SpyLite Trace Window
Bluetooth commands and the responses to those commands are displayed in this window in the sequence that they are executed, depending on user configuration (Figure 1).
The trace information that is displayed is configurable; the options are described later in this document.
3 Menus & Toolbar
Figure 2 shows the Menu items and Icon shortcuts of the SpyLite interface.
Each icon displays a ToolTip (ScreenTip) when the cursor is over it.
The remainder of this section describes the individual menu items and the selections within each.
3.1 FILE MENU
The File menu (Figure 3) has one option: Exit, which closes the SpyLite application.
3.2 EDIT MENU
The Edit menu (Figure 4) has one option: Find in Trace.
This icon – — will also access Find in Trace dialog box (Figure 5).
Figure 4: Find in Trace option
Find in Trace allows the user to locate a word or group of words in the trace window.
• Type the text string to be found in the Find what: field.
• Check the “Match whole word only” and/or “Match case” options, as appropriate, and click Find All to execute the search.
The Trace window must be the active window, i.e., it must have the “focus.”
Each instance of the search string will be highlighted in the trace window.
3.3 TOOLS MENU
The Tools menu (Figure 6) contains two groups of functions:
• Format/File Logging Options...—sets text and background colors; sets the font and font size; sets log file options.
• Set Trace/Clear Trace Options—controls the display and level of trace messages; clears the trace window
3.3.1 Format...
Displays a dialog box with two tabs (Figure 7):
• Trace Colors (Figure 7)—displays a list of trace items for which custom text colors and background colors can be set using the Windows color-picker. To set the trace colors:
a) Click Tools > Format… and the Trace Colors tab.
b) Double-click an item, e.g., “Error trace,” in the list (Figure 7) to change its color properties. The background color picker (Figure 9) appears.
c) Choose a background color from the color picker and click OK.
d) A second color picker appears to allow the selection of the text color. Choose a text color and click OK.
The “Default” button on the Trace Colors tab resets the background and text colors to their original settings.
• Set Font (Figure 8)—provides a means to select the font and font size of the text in the Trace window. To change the font and font size:
a) Select Tools > Format… and the Set Font tab
b) Choose a font from the drop-down menu. A sample of the font style appears in the Preview section of the dialog box.
c) Choose a font size from the drop-down menu.
d) Click OK to apply the choices and close the Color and Font Options dialog box.
The Default button resets the text font style and size in the Trace window to the default, Courier New, nine points.
HelpDrivers Since March 2000